每一分硬币
都值得守护

关于均线、乖离率、抵扣价的富途代码

均线、乖离率、抵扣价的概念来自Lonecapital,在B站和油管可以搜到他的视频,知乎上也有很多答主对于均线有深刻理解,建议大家自己搜一下。下面的代码是在其他朋友的协助下把TV的指标换成了富途的指标,参数可以自己根据自己的交易周期调整,如果保存或者编译不成功,自己看一下错误代码提示和函数的使用案例,在富途的指标管理页面都有。

移動平均線|SMA & EMA|雙均線交易系統
(来自 Youtube LEI & LoneCapital 频道)

趋势交易:MA20\60\120+EMA20\60\120 + K线标记颜色 + 抵扣价 指标

MA20:MA(CLOSE,20),COLORFF8D1E;
MA60:MA(CLOSE,60),COLOR0CAEE6;
MA120:MA(CLOSE,120),COLORE970DC;
EMA20:EMA(CLOSE,20),DOTLINE,COLORFF8D1E;
EMA60:EMA(CLOSE,60),DOTLINE,COLOR0CAEE6;
EMA120:EMA(CLOSE,120),DOTLINE,COLORE970DC;

{收盘价低于EMA20且MA20向下拐头,红色}
STICKLINE(C<EMA20 AND MA20<REF(MA20,1),O,C,0.8,0),COLORRED; STICKLINE(C<EMA20 AND MA20<REF(MA20,1),H,L,0.08,0),COLORRED;
{收盘价高于EMA20且MA20向上拐头,绿色}
STICKLINE(C>EMA20 AND MA20>REF(MA20,1),O,C,0.8,0),COLORGREEN; STICKLINE(C>EMA20 AND MA20>REF(MA20,1),H,L,0.08,0),COLORGREEN;
{其他灰色}
STICKLINE(NOT ((C>EMA20 AND MA20>REF(MA20,1)) OR (C<EMA20 AND MA20<REF(MA20,1))),O,C,0.8,0),COLORGRAY;
STICKLINE(NOT ((C>EMA20 AND MA20>REF(MA20,1)) OR (C<EMA20 AND MA20<REF(MA20,1))),H,L,0.08,0),COLORGRAY;
DRAWICON(CURRBARSCOUNT=21,C,41);
DRAWICON(CURRBARSCOUNT=61,C,41);
DRAWICON(CURRBARSCOUNT=121,C,41);

趋势交易:乖离率

CS:(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100,LINETHICK1,COLORFF8D1E;
SM:(MA(CLOSE,20)-MA(CLOSE,60))/MA(CLOSE,60)*100,LINETHICK1,COLOR0CAEE6;
ML:(MA(CLOSE,60)-MA(CLOSE,120))/MA(CLOSE,120)*100,COLORSTICK;

备注:原文作者使用MA作为乖离率指标,但雷公的Blog提供的TV代码使用的是EMA指标,他本人的说法是,使用EMA可以达到所见即所得。)

说明:MA+EMA是传统均线的思维,因为MA有滞后性,相对EMA各有利弊,日内交易我是不看MA只看EMA的,增加了抵扣价(图中小黄点)是可视化当前价格运行的方向是不是有可能改变MA的走势, 起到一个预判作用。

指标添加界面截图

注意红框部分,编译或保存不成功底部会有对应的提示,右侧指标的缩写和全名需要填写,如果全部复制上面的代码保存不成功,估计是符号半角全角的问题,比如复制;变成了;具体要看底部的错误提示做对应的调整就好。

赞(4)
如是本站原创文章,未经允许不得转载:投资笔记 » 关于均线、乖离率、抵扣价的富途代码

评论 抢沙发

7 + 8 =
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址